If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2010 Ford Taurus LT ELECTRICAL ISSUES

Post Reply
Jonadams197
New Member
Posts: 2
Joined: Thu May 16, 2019 11:01 am
Vehicle: 2010 Ford Taurus Limited

2010 Ford Taurus LT ELECTRICAL ISSUES

Post by Jonadams197 » Thu May 16, 2019 11:05 am

I’m having problems with my car...I have a 2010 Ford Taurus and I got the rack and pinion replaced everything is fine with steering, but now my stereo or climate control buttons wont work air stuck at 90* on defrost and to make it worse as I’m driving my dash board keeps coming on and off like the car was just started. It doesn’t effect how the car drives because it drives perfect. I don’t know what’s going on HELP PLEASE!.


mope
Regular Member
Posts: 164
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: 2010 Ford Taurus LT ELECTRICAL ISSUES

Post by mope » Mon May 20, 2019 6:55 pm

I would be looking for a grounding issue given those symptoms, but it's impossible to diagnose over the internet.

These really are (unfortunately) the times to take it to the dealer for proper diagnoses.

13FTPI_driver
New Member
Posts: 8
Joined: Mon Jul 03, 2017 11:51 am
Vehicle: 2013 Taurus Police Interceptor

Re: 2010 Ford Taurus LT ELECTRICAL ISSUES

Post by 13FTPI_driver » Sat Jun 29, 2019 8:08 pm

Does this car have a history of water immersion? I see a lot of bizarre and frequently transient electrical symptoms if any of the electrical control systems from the ECM have moisture or (next step) corrosion on the conductors - can do all kinds of annoying things. Be aware the braided electrical wire can also "wick" water up inside the insulation if it isn't protected.

Jonadams197
New Member
Posts: 2
Joined: Thu May 16, 2019 11:01 am
Vehicle: 2010 Ford Taurus Limited

Re: 2010 Ford Taurus LT ELECTRICAL ISSUES

Post by Jonadams197 » Sat Jun 29, 2019 8:12 pm

Thank you I’ll try to check these things out

Post Reply