If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

My engine just went

Post Reply
13_3.5_turbo_fpis
Regular Member
Posts: 10
Joined: Fri Jan 04, 2019 2:39 am
Vehicle: 2013 fpis 3.5 L ecoboost

My engine just went

Post by 13_3.5_turbo_fpis » Thu Apr 04, 2019 10:37 am

I have a 2013 Ford Taurus 3.5 turbo and I'm at 122,000 miles , engine was burning oil, now I have to get the engine rebuilt, has to be bad engine valves or pistons


TerryY
Regular Member
Posts: 45
Joined: Sat Sep 24, 2016 9:12 pm
Vehicle: 2013 Police Interceptor Sedan

Re: My engine just went

Post by TerryY » Thu Apr 04, 2019 12:15 pm

OR a turbo seal

Jake_Blues
Regular Member
Posts: 37
Joined: Sun Jan 27, 2019 8:25 pm
Vehicle: 2013 Police Interceptor Sedan

Re: My engine just went

Post by Jake_Blues » Thu Apr 04, 2019 5:32 pm

bummer dude - sorry to hear that.

if it's going to be a new/rebuilt engine it's almost worth it to get a another 2013/2014 at auction/Copart to do a transplant.

13_3.5_turbo_fpis
Regular Member
Posts: 10
Joined: Fri Jan 04, 2019 2:39 am
Vehicle: 2013 fpis 3.5 L ecoboost

Re: My engine just went

Post by 13_3.5_turbo_fpis » Fri Apr 05, 2019 8:06 am

They are replacing the engine valve seal , only going to cost me $300

Jake_Blues
Regular Member
Posts: 37
Joined: Sun Jan 27, 2019 8:25 pm
Vehicle: 2013 Police Interceptor Sedan

Re: My engine just went

Post by Jake_Blues » Fri Apr 05, 2019 1:46 pm

wow! lucky that!

mymangochutney
Regular Member
Posts: 114
Joined: Thu Jun 14, 2018 9:50 pm
Vehicle: Taurus FPIS 2013

Re: My engine just went

Post by mymangochutney » Mon Apr 08, 2019 3:00 pm

13_3.5_turbo_fpis wrote:
Thu Apr 04, 2019 10:37 am
I have a 2013 Ford Taurus 3.5 turbo and I’m at 122,000 miles , engine was burning oil, now I have to get the engine rebuilt, has to be bad engine valves or pistons
isn't a used engine $600?

Post Reply