If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Overheating, second verse

Post Reply
bradleyheathhays
Regular Member
Posts: 13
Joined: Wed Feb 07, 2018 2:42 am
Vehicle: 02 Ford Taurus SES 3.0

Overheating, second verse

Post by bradleyheathhays » Wed Sep 12, 2018 3:41 pm

Sorry to start another thread but I'm desperate to get this fixed fast as it's really costing me not having this vehicle on the road now.

Got a '11 Crown Vic that's been overheating because the rad fan hasn't been kicking on when it should. I replaced the fan and fan controller with a new unit and it's still not working right. Sometimes the fan kicks on when I turn the a/c on, and other times it doesn't. Sometimes it turns on when the engine gets hot and sometimes it doesn't.

Water pump is known to be good, flushed system both ways and the thermostat is new.

Any ideas?


mope
Regular Member
Posts: 135
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: Overheating, second verse

Post by mope » Wed Sep 12, 2018 4:54 pm

I think you'll see a lack of responses as you're posting in the 2010+ taurus forum. We're better versed in the current gen 3.5/3.7 than your modular 4.6 (I believe that's what all the last CV's had, right?). You'd probably be better off looking for a CV.....or CVPI......page for help.

warment
Regular Member
Posts: 913
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Overheating, second verse

Post by warment » Fri Sep 14, 2018 12:03 pm

Bad coolant temp sensor? What is your temp gauge reading on the dash?
2005 Ford Five Hundred SE
6-spd auto

Post Reply