If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2001 Ford Taurus service engine light

Post Reply
DjandMike91110
New Member
Posts: 1
Joined: Mon Apr 17, 2017 3:05 pm
Vehicle: 2001 Ford Taurus

2001 Ford Taurus service engine light

Post by DjandMike91110 » Mon Apr 17, 2017 3:15 pm

I need help. We have a 2001 Taurus. No clue about Vulcan motor or not. Wouldn't know how to find out. Service engine light has been on since we bought her 2 months back. She's our daily driver and the engine normally runs very well. We noticed the egr sensor was melted and have been trying to repair/replace it. Boyfriend found one at junk yard on a Taurus a couple years newer and pulled it off. However the connectors are not compatible. Is there a way to solve this issue without having to buy a new egr sensor? I read somewhere in a forum that they're no longer making them. I could be wrong but, boyfriend likes to save money if he can. Any help or information would be appreciated.

ChartGuy
Regular Member
Posts: 253
Joined: Mon Feb 04, 2013 6:01 pm

Re: 2001 Ford Taurus service engine light

Post by ChartGuy » Tue Apr 18, 2017 1:18 pm

Part is available on Rockauto see '01 Vulcan engine = OHV, Ford part DPFE4 $34.79, cheaper part available. However, most likely your cat is plugged making too much pressure and pushing the hoses off, or one making it too hot.

warment
Regular Member
Posts: 886
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: 2001 Ford Taurus service engine light

Post by warment » Wed Apr 19, 2017 4:50 am

I was thinking the same thing (cat). Has to be running very hot to do that. A bad oxy sensor probably killed the cat, so replacing the cat will probably only be a temp fix. Replace the oxy sensors as well.
2005 Ford Five Hundred SE
6-spd auto

Post Reply