If you shop at Amazon.com (for anything), use this link to help support FordTaurus.net!

How are Mercury Montego fog lights mounted?

Discuss anything about the exterior here - e.g. paint, styling, colors, wheels, etc.
gtyates
New Member
Posts: 2
Joined: Sat Feb 11, 2017 6:21 pm

How are Mercury Montego fog lights mounted?

Postby gtyates » Sat Feb 11, 2017 6:24 pm

I was cleaning my grandmother's 2005 Montego today and noticed that the drivers side fog light is a bit loose. The passenger side is much tighter by comparison. How are these fog lights mounted and what is the best way to access them? All suggestions appreciated..
Greg


BobM
Regular Member
Posts: 36
Joined: Tue Dec 01, 2009 5:47 pm

Re: How are Mercury Montego fog lights mounted?

Postby BobM » Sun Feb 12, 2017 7:42 pm

Here is the page from the service manual

https://dl.dropboxusercontent.com/u/55361551/Fog%20Lamps.pdf
2005 Five Hundred SEL
Titanium Green

gtyates
New Member
Posts: 2
Joined: Sat Feb 11, 2017 6:21 pm

Re: How are Mercury Montego fog lights mounted?

Postby gtyates » Tue Feb 14, 2017 10:56 am

Thank you!! Getting to it looks like it might be a small challenge, but I think I can remove the 3 bolts next to the driver's side front tire and loosen the bumper cover enough to give me a little room to work on it. Looking at the diagram, and based on how the fog lamp is loose, I think I may be purchasing her a replacement unit. The bracket felt solid, but the lamp itself has significant movement. I think it is possible either she lightly bumped something or someone lightly tapped her bumper on that corner and has broken the lamp loose from the bracket. Stuff happens! Unrelated, but I had to replace one of her rear tail light assemblies due to moisture on the inside. There was standing water in the bottom of the housing, which had rusted the turn and reverse bulbs. Fortunately with a new housing and some replacement bulbs (and lots of dielectric grease) everything is working properly. There was no damage to the rear assembly, so I have to assume seal went bad. I guess.


Return to “Exterior”



Who is online

Users browsing this forum: No registered users and 0 guests