If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

HELP! 2006 Ford 500 AC Wiring Etc

Post Reply
LantanaTX
New Member
Posts: 1
Joined: Thu Sep 03, 2015 7:55 am

HELP! 2006 Ford 500 AC Wiring Etc

Post by LantanaTX » Thu Sep 03, 2015 8:26 am

Hello,
I am new to this forum. My daughter dropped off her 2006 Ford 500 with me to take a look at. She was complaining that the ac wouldn't always come on and that the radio, dash and speedo would do stupid things.

That night I checked the battery alternator and battery cables. I cleaned the terminals but could find nothing wrong. I drove it around at night and everything seemed fine. Yesterday when it was much hotter out here in Texas, I went on a 10 mile drive. The ac stopped blowing cold as soon as I left the driveway but other than that seemed to run OK. Last night I tried this again but the ac wouldn't come on. The compressor would not come on. I checked the ac clutch fuse and relay, all was good but the compressor would not come on. I started the car again and decided to go for a drive. The ac was just blowing hot air so I turned it off. Then I turned the ac back on hoping to get lucky with some cold air. When I did this, all the interior lights, dash, headlights, radio went black for a couple of seconds then came back on. While the dash and interior lights came back on the engine ran a little rough and the headlights were pulsing. I turned the ac back off and within a short amount of time the engine smoothed out and the headlights were stable.

While searching for this problem, I found this site where someone mentioned a problem with cold solder joints on the dash. I had a similar problem with cold solder on a Crossfire and it was easy to fix if you know with component to look at. Since the problem seems to be associated with the use of the ac, I am not sure if the dash is the problem or possibly the ac control.

Anyone had this issue?


Post Reply