If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Wrench light

Discuss anything else about the car
Post Reply
warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Wrench light

Post by warment » Sat Oct 24, 2015 5:51 am

My 2005 Five Hundred 6 speed auto lost power after the wrench light came on while my brother was driving. He turned the car off and back on and everything was fine. Internet searches point to throttle body, pedal sensor, or trans. Thoughts?
2005 Ford Five Hundred SE
6-spd auto


warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Sat Oct 24, 2015 5:52 am

Forgot to mention, after this happened, I cleaned the throttle body and MAF. Both werent too dirty. Also cleaned my batt terminals. Car has 250k miles.
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Mon Oct 26, 2015 8:20 am

Drove the car over 50 miles this morning without issue.
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Tue Nov 03, 2015 6:31 pm

Got the wrench light again today on the way home. I was able to pull the codes before I restarted the car...P2104 and 2111...

Does anybody have any thoughts/recommendations? Sounds like I need a new throttle body? If I buy and install, will my car have any issues with the new tb?
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Wed Nov 04, 2015 11:57 am

So...I ordered a new pedal assembly yesterday and a new throttle body (heated style, remanufactured, Cardone 67-6007) today. Wrench light came on again this morning. Restart of engine and everything was fine again...same codes...
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Thu Nov 05, 2015 1:30 pm

Saga continues...ordered from partstrain...they cancelled the order because they had none in stock...ordered from stylintrucks (showed a positive quantity on their website)...they canceled the order because they had none in stock.

Trying to confirm from a seller on ebay that they have one before I order again. Sent an email to carpartkings as well in an attempt to verify that they have one before I order from them.
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Fri Nov 06, 2015 7:32 am

Apparently, they used to sell just the electronic side of the throttle body (part pbt-gf20-gs20), but now you have to purchase the whole thing. I ordered one from another vendor on ebay last night.
2005 Ford Five Hundred SE
6-spd auto

The Bone
Regular Member
Posts: 390
Joined: Fri Jan 17, 2014 11:41 am

Re: Wrench light

Post by The Bone » Sun Nov 08, 2015 8:06 pm

Al the you may need is a throttle position sensor. You dont need a new throttle body or gas peddle. They sell them at NAPA

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Sun Nov 08, 2015 8:17 pm

Thanks Bone. I have ordered a new throttle body and pedal assembly. My original plan was to install a new pedal first and then a tb if that didnt work. After getting the wrench a second time myself, I said screw it and threw money at it. I will make another post once I get them both installed.
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Sat Nov 14, 2015 5:21 pm

I replaced both the throttle body and accel pedal today. Disconnected the batt for over an hour during the install. When I plugged the batt back up and turned the key on for the first time, I could hear the reman throttle body sweep through all positions and back...this is the reset procedure...

Pedal install took longer than the tb. It had a single elec collector and was held in place by 3 button head bolts with a hex center. Bolt on the bottom was longer than the top two.
2005 Ford Five Hundred SE
6-spd auto

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Sun Nov 15, 2015 5:43 pm

The car ran great today...seemed more responsive...no wrench light.
2005 Ford Five Hundred SE
6-spd auto

Woganm
New Member
Posts: 9
Joined: Tue Jun 14, 2016 1:40 pm
Vehicle: 2006 Ford freestyle
Contact:

Re: Wrench light

Post by Woganm » Fri Jun 17, 2016 9:00 pm

I reset the car it ran good and then the wrench light came back on and eng light drove home shut off started back up wreach light went off got to go 3 miles came back on ever time I shut off it would go off for a few then back on

Woganm
New Member
Posts: 9
Joined: Tue Jun 14, 2016 1:40 pm
Vehicle: 2006 Ford freestyle
Contact:

Re: Wrench light

Post by Woganm » Wed Jun 22, 2016 6:18 pm

Woganm wrote:I reset the car it ran good and then the wrench light came back on and eng light drove home shut off started back up wreach light went off got to go 3 miles came back on ever time I shut off it would go off for a few then back on

VinnyB
New Member
Posts: 2
Joined: Tue Feb 28, 2017 12:29 pm
Vehicle: 2006 Ford Five Hundred

Re: Wrench light

Post by VinnyB » Tue Feb 28, 2017 12:34 pm

I am having this problem is there any definitive fix? Sometimes it will surge but the other day on way home I lost power from the pedal. RPM's would rise but wouldn't go any faster. Turning off and sitting hasn't fixed the problem. At idle with car in park it starts fine but when I hit the pedal it's sluggish and won't go above 2k RPM.

VinnyB
New Member
Posts: 2
Joined: Tue Feb 28, 2017 12:29 pm
Vehicle: 2006 Ford Five Hundred

Re: Wrench light

Post by VinnyB » Tue Feb 28, 2017 12:34 pm

Oddest part of the problem though is I get no check engine or wrench light at all.

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: Wrench light

Post by warment » Tue Feb 28, 2017 12:37 pm

Just to update...I have had zero problems since replacing the TB and pedal assembly. I wish you guys the best on this situation.
2005 Ford Five Hundred SE
6-spd auto

The Bone
Regular Member
Posts: 390
Joined: Fri Jan 17, 2014 11:41 am

Re: Wrench light

Post by The Bone » Wed Mar 01, 2017 2:43 pm

Have you checked the gas cap. It will set a CEL every time.

Post Reply