If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2005 Mercury Montego Premiere AWD transmission P0701 and P0707

Discuss anything related to the engine, electronics, transmission, etc.
Post Reply
Nolimifool
New Member
Posts: 2
Joined: Sun Sep 17, 2017 11:08 am
Vehicle: 2005 Montego Premier AWD

2005 Mercury Montego Premiere AWD transmission P0701 and P0707

Post by Nolimifool » Sun Sep 17, 2017 12:04 pm

My 1st sympton was, I noticed I was getting real bad gas mileage for a week or so, then CEL, wrench light, check transmission message, and Check Engine message all lit up pretty much at the same time........ The car stayed running, but I had no throttle. I hit the gas peddle all the way to floor and nothing, it just idles. When in park and i hit the gas the RPM's will go up normal, but in Drive or Reverse nothing, if im lucky i can get it to crawl a few feet. Have a Generic P0701 code and P0707 code. The latter points to the Neutral safety switch/Transmission Position Sensor. Can someone tell me where that is located so I can check it, I can not find the damn thing, would it be in the pan? Any help is appreciated, Thank you


Nolimifool
New Member
Posts: 2
Joined: Sun Sep 17, 2017 11:08 am
Vehicle: 2005 Montego Premier AWD

Re: HELP!! Please.... my 2005 Mercury Montego Premiere AWD

Post by Nolimifool » Sun Sep 17, 2017 8:16 pm

Image

I found where it is :?
Attachments
Capture+_2017-09-17-19-40-23.png
Capture+_2017-09-17-19-40-23.png (231.63 KiB) Viewed 365 times

Post Reply