If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Discuss anything related to the interior here - e.g. seats, audio system, etc.
500blue
New Member
Posts: 1
Joined: Sun Dec 04, 2016 7:47 am
Vehicle: 500 sel 05

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by 500blue » Sun Dec 04, 2016 7:52 am

We just moved and had no mechanic. Someone recommended a mechanic and he had him do a tune up. After putting the battery back, the cluster is completely dead. He run tests and adter them he says that I need to replace the cluster. Is this related to these posts? Should I try what you guys are suggesting? Or should I just buy a cluster new/used to install it?


Nikitos
New Member
Posts: 1
Joined: Wed Dec 28, 2016 1:16 am
Vehicle: Five Hundred 2005

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Nikitos » Wed Dec 28, 2016 1:26 am

Hello there! I`m from Russia and its so hard to have Five Hundred in my country, because its very exclusive here, but I really love this car! And u`ve made me so happy! Last 2 month I was having a problem with my dashboard and cant fix it by myself. But yesterday I read this theme and it really helped me!!! I made all as u advised and solve this problem! Thank u man, really thanx))))

moliddy
New Member
Posts: 1
Joined: Fri Jan 06, 2017 10:29 am
Vehicle: 2005 Fivehundred SEL

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by moliddy » Fri Jan 06, 2017 10:44 am

Hello... I'm having this same exact problem with my 2005 Fivehundred... I feel that I can pull the cluster ok but would like to see the pictures of what solder points on the back of the cluster to inspect. I've had this car since new and would really like to get this fixed..

Thanks,
Mark

jlkeene
New Member
Posts: 1
Joined: Sun Jan 22, 2017 2:39 pm
Vehicle: 2005 Ford 500 LTD

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by jlkeene » Sun Jan 22, 2017 2:48 pm

Like some others I removed the instrument cluster and the solder joints did not look bad, however resoldering both of them did the trick. Many thanks

If you're not familiar with soldering make sure you also heat the contact post that is in the solder, just dropping more solder on it often will not work. Just don't heat it too much or you'll damage the component on the other side.

Also for those looking on how to get the cluster out there is a nice video on YouTube showing how simple it is.
https://www.youtube.com/watch?v=L8FtzSstQ1Q

Joekerfoe
New Member
Posts: 2
Joined: Sat Feb 04, 2017 1:34 pm
Vehicle: 2005 ford 500

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Joekerfoe » Sat Feb 04, 2017 1:47 pm

Hi ibw88 thank you for the advice on this fix. I took a chance and took the cluster out,bought a cheap soldering iron and applied the solder. Worked great! No more flickering gauges or blacked out cluster. You r the Man!

Joekerfoe
New Member
Posts: 2
Joined: Sat Feb 04, 2017 1:34 pm
Vehicle: 2005 ford 500

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Joekerfoe » Sat Feb 04, 2017 1:49 pm

Hi jlkeene thank you also for the link to take the dashboard apart. Piece of cake!

Deengu
New Member
Posts: 4
Joined: Wed Jun 24, 2015 12:39 am

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Deengu » Sun Mar 26, 2017 1:56 pm

Great fix. Another thing of note: when my cluster panel malfunctioned, the rear reverse brakes came on, even while in drive. If you also have this symptom, this fix is for you.

Jongibson
New Member
Posts: 1
Joined: Thu Jun 15, 2017 2:01 pm
Vehicle: 2005 Ford Five Hundred Limited

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Jongibson » Thu Jun 15, 2017 2:08 pm

This may help many of you if this problem isnt the cluster. Just had the same problem. Only my soldering was tight and perfect. Obviously I could have soldered to solve the problem but I didn't have a gun so I ordered from amazon. While youtubing this problem to make sure I fixed it correctly, youtube rolled over to another video about common five hundred issues. I though it was likely unrelated but watched anyway. The main wire harness for the motor on the passenger side rests on an a/c line. Over time the harness gets chewed through and will eventually cause a major failure. I thought I would check mine as the video mentioned nothing about instrument cluster problems. Mine was just starting to get chewed through. I relocated it by pulling on it with a long metal hook I made and then retaped it. Re-assembled the cluster and boom it works! I need to really repair the harness but it works for now. I worked at a Ford dealership as a service manager for a few years but can't remember if the harness is directly tied to either powering or grounding the cluster. Either way the car is fixed. Hopefully you guys will have luck. If you need a link, let me know!

MBJan
New Member
Posts: 1
Joined: Thu Jun 22, 2017 11:56 am
Vehicle: 2006 Mercury Montego Luxury

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by MBJan » Thu Jun 22, 2017 12:12 pm

HI! IM having the same problem w/2006 Merc Montego & IM not a mechanic. However, I have found a local electronics guy who can do the solder job if a local mech (he recommended one) can take out the cluster & reinstall, saving hundreds of $$$. Before I start the process, one question. The dealership had told me they would have to replace the module..take it out, send to the factory to set odometer on the new one, etc., return to dealership for reinstallation...some kind of law requirement...BIG expense, several days in the shop. My question: when you remove the module to do this repair, does the odometer, oil life, etc. go to zero or does it stay in a memory? Thanx for your help.

dokterj
New Member
Posts: 1
Joined: Wed Jul 26, 2017 9:09 am
Vehicle: 05 ford 500

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by dokterj » Wed Jul 26, 2017 9:24 am

does anybody still have pics of which post needs to be soldered?

Clb1024
New Member
Posts: 1
Joined: Mon May 15, 2017 2:44 pm
Vehicle: 06 Ford 500

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Clb1024 » Tue Aug 08, 2017 5:49 pm

Does anyone have a picture my car is out of service.

05ford500
New Member
Posts: 1
Joined: Tue Sep 19, 2017 9:06 pm
Vehicle: Ford 500

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by 05ford500 » Thu Sep 21, 2017 5:13 pm

Unable to see the pics. Any way to get that issue resolved? Thanks - working on '05 Ford 500 - no issues for 12 years until this week.

Nckernst79
New Member
Posts: 1
Joined: Wed Nov 15, 2017 6:36 pm
Vehicle: Ford five hundred

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Nckernst79 » Wed Nov 15, 2017 6:40 pm

Trying to fix instrument cluster with soder which joint is normally wrong they all look good to me but iam having same exact issues as you were please send or post picture of it thanks

boag1
New Member
Posts: 2
Joined: Wed Feb 14, 2018 8:17 pm
Vehicle: 2005 five hundred

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by boag1 » Thu Feb 15, 2018 2:55 pm

this is an interesting if not current thread. I've had a similar problem for the last 4-5 years. The lights would flicker on the dash/headlights/radio etc (intermittent but not bad) and I learned too live with it (I learned a new term for it recently - poltergeist). I do a lot of my own work on cars but the shop I do use over the years wouldn't switch out the alternator since they didn't think that would solve the problem.

However this week while on a trip I had to hit passing gear (which seems to aggravate the problem) and the gauges went wild, the alternator light came on (which has never happened) and everything looked like a complete engine failure - the severity of this has never happened in the past. Pulled over, stopped the car and when I restarted everything was OK.

Now two days later I have driven the car for a couple hundred miles while out of town and no issues. I'm starting to lean toward instrument cluster but the passing gear deal still makes me wonder.

Any thoughts out there?

zadmat
New Member
Posts: 1
Joined: Sat Apr 21, 2018 6:08 am
Vehicle: 2006 ford five hundred

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by zadmat » Sat Apr 21, 2018 6:48 am

does anyone have pictures of where on instrument panel needing soldering?

boag1
New Member
Posts: 2
Joined: Wed Feb 14, 2018 8:17 pm
Vehicle: 2005 five hundred

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by boag1 » Wed Apr 25, 2018 5:54 pm

a final note. On the outside chance it was the alternator - which ALWAYS showed good, I replaced it. Problem solved. I have never had an alternator gradually (intermittently) fail over a four year period......

Custom Coffin Works
New Member
Posts: 1
Joined: Sun Aug 26, 2018 2:56 pm
Vehicle: 2005 Montego Premier

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Custom Coffin Works » Tue Sep 25, 2018 12:34 pm

My dash works perfectly with no issues, however my climate control is not turning on the AC compressor. Everything on the climate control was check at the shop and the diagnose is the climate control is not talking with the instrument cluster. What should I look for? This a solder issue too? (Mercury Montego 2005)

Akutch22
New Member
Posts: 2
Joined: Sat Sep 29, 2018 10:00 pm
Vehicle: 2005 ford 500 limited AWD

Re: 2005 Ford 500 Intermittent Cluster/Dashboard Issue Solved

Post by Akutch22 » Sat Sep 29, 2018 10:08 pm

does the instrument panel need reprogramming by a ford dealer if i was to do this

Post Reply