If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Audio System Upgrade

Discuss anything related to the interior here - e.g. seats, audio system, etc.
Post Reply
cratra
Regular Member
Posts: 13
Joined: Sat Aug 27, 2005 9:10 am
Location: KC, MO

Audio System Upgrade

Post by cratra » Sun Aug 28, 2005 1:48 pm

I have read the previous post on upgrading the audio system in the 500's. Just curious if any one knows of a good 6X9 subwoofer(not a coax) that you could add with an aftermarket amp. Don't really want to modify alot of things. The only one I have found is at
[url]http://www.avincar.com%20%20I%20have%20sent%20them%20a%20request%20on%20prices%20so%20when%20I%20get%20them%20I%20will%20post%20them.[/url]


cratra
Regular Member
Posts: 13
Joined: Sat Aug 27, 2005 9:10 am
Location: KC, MO

Post by cratra » Mon Aug 29, 2005 7:26 pm

The Avincar 6X9 subwoofers are $125.00 per pair + shipping. I am going to order a pair and see how they fit and sound, then I will add an aftermarket amp and let you know.

akajones
Regular Member
Posts: 206
Joined: Thu Jun 23, 2005 4:46 pm
Location: Lisbon, CT

Post by akajones » Mon Aug 29, 2005 9:51 pm

Please do, I'm curious how much sound we can get out of the free air 6X9's.
2005 Montego Premier AWD--- Norsea Blue with every available option & tinted windows

User avatar
Toaderly
Regular Member
Posts: 2166
Joined: Sun Jul 31, 2005 7:36 am
Location: Des Moines, IA
Contact:

Post by Toaderly » Tue Aug 30, 2005 6:02 am

I've thought about upgrading the sound system until I came under the realization that my hearing isn't what it used to be. I think it was that Iron Maiden concert I went to in 1985 (I was eighteen). I couldn't hear for almost two weeks afterwards. The stock system is probably about as good enough as I need - although, I'm still considering an upgrade. Let us know how the new 6x9's sound, cratra.

Smokeshow
Regular Member
Posts: 121
Joined: Tue Aug 02, 2005 1:16 pm
Location: Florida
Contact:

Post by Smokeshow » Tue Aug 30, 2005 8:13 am

I was thinking that these cars should of come with 6 speaker systems to begin with. And a sub in the trunk as an option.
08 Mercury Sable
02 Svt Focus

black2005
Regular Member
Posts: 486
Joined: Sun Sep 04, 2005 4:10 pm
Location: DSM IA

Post by black2005 » Sun Sep 04, 2005 9:51 pm

I have a SE so I don't have the rear 6x9 speakers.......... anyone know if the factory harness has wires back there ready for speakers... the cut outs are there and and doubt FORD would use a different wire harness....

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Post by warment » Wed Sep 07, 2005 6:00 am

I too would like to know if the same harness is used. I would also like to know if my SE already has an amp jack as well.

I looked under the rear deck and did not see any "dangling plugs," but I don't know for sure.

Bill

JBirdZee
Regular Member
Posts: 104
Joined: Sat Aug 20, 2005 8:11 am
Location: Batavia, NY

Post by JBirdZee » Wed Sep 14, 2005 9:45 pm

Guys...... I would check under the driver side trunk floor carpet panel (You need to remove the side carpet panel, the amp is bolted to the driver side bottom of the car, just behind the driver side rear wheelwell. There are two harnesses that plug into the aftermarket amp, 1 has power and audio INTO the amp, the other harness goes directly to the 6x9s in the rear deck, which, since this harness is pretty much standalone in function, would explain why it is missing on the SE.

I'm curious if that Power/Audio in connector is down there on the SE.

It could also be that you have the harness, but the radio side of the harness isn't connected either. The non-audiophile headunits might not have subwoofer out.
500 Limited AWD '05
Dark Shadow Gray

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Post by warment » Tue Sep 20, 2005 6:29 am

Yeah. I would guess that the harness is there, but the amp and rear deck speakers are not.

Bill

warment
Regular Member
Posts: 921
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Post by warment » Sat Sep 24, 2005 3:54 pm

For you guys that are curious about the existence of an amp harness in the SE model:

I just pulled the left rear carpet from the trunk of my SE and did not see any amp harness. There are only 2 wires back there, one for the trunk light, and one for the license plate lights.

I was hoping that the harness would be there to tap into for my Rockford amplifier.

I guess I will have to upgrade my stereo in the near future.

Bill

Post Reply