If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2004 Taurus runs rough when taking off

Post Reply
KenP
New Member
Posts: 1
Joined: Wed Mar 21, 2018 10:38 am
Vehicle: Taurus 2004

2004 Taurus runs rough when taking off

Post by KenP » Wed Mar 21, 2018 10:48 am

Hi, said Taurus does not have check engine light on but starting missing/skipping when taking off. Thought it might be bad gas but had cables and plugs changed cause they originals. Plugs and cables made no difference. Refilled tank with gas and used some injector cleaner but that hasn't changed anything. The car runs fine after getting up to speed but misses / skips on take off. Any suggestions will be greatly appreciated.


warment
Regular Member
Posts: 923
Joined: Wed Aug 31, 2005 6:13 am
Location: Virginia

Re: 2004 Taurus runs rough when taking off

Post by warment » Fri Mar 23, 2018 1:32 pm

Vulcan? If so check the rubber pcv elbow on top of the intake. My mom's had a crack in it that caused the car to run badly.
2005 Ford Five Hundred SE
6-spd auto

Magus732
Regular Member
Posts: 36
Joined: Sun Apr 01, 2018 1:34 pm
Location: Columbus, OH area
Vehicle: 2000 Taurus SE Comfort

Re: 2004 Taurus runs rough when taking off

Post by Magus732 » Sun Apr 01, 2018 2:39 pm

Does it get better once the engine warms up, or is it constant? If it's constant, it could be a vacuum leak. If it goes away when your engine warms up, you probably have a bad MAF sensor.
2000 Taurus SE Comfort - Graphite Blue - 3.0L Vulcan FFV
2011 Taurus SEL - Tuxedo Black - 3.5L Duratec 35

Diggi
New Member
Posts: 2
Joined: Mon Apr 02, 2018 9:13 am
Vehicle: 2007 Ford Taurus SE

Re: 2004 Taurus runs rough when taking off

Post by Diggi » Mon Apr 02, 2018 9:18 am

Your vacuum hoses are dry rotted. replace them.. You can only get that part at the dealer.

Post Reply