If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Lost trim piece, anyone have this happen?

Discuss anything about the exterior here - e.g. paint, styling, colors, wheels, etc.
Post Reply
yowen
Regular Member
Posts: 55
Joined: Thu Jun 17, 2010 8:17 pm
Location: Michigan
Contact:

Lost trim piece, anyone have this happen?

Post by yowen » Tue Oct 12, 2010 8:33 pm

I lost the trim piece between the doors and the roof, runs from front to rear window in same color as the rest of the car.

Anyone else have this happen? Any idea how I might have lost it?

Most importantly if I replace, how do i stop it from happening again.
2006 Ford 500 SE, Dark Blue, 116,000 Miles
- JVC KD-LHX500 Deck


Edsel II
Regular Member
Posts: 531
Joined: Wed Jul 25, 2007 2:38 pm

Re: Lost trim piece, anyone have this happen?

Post by Edsel II » Wed Oct 13, 2010 11:30 am

This problem has come up before - seems like they were getting ripped off in carwashes. Ford was repairing them under warranty, and I think there is a TSB on them regarding faulty mounting clips if you look in the TSB listings. Of course, if you are out of warranty, that won't help much.

yowen
Regular Member
Posts: 55
Joined: Thu Jun 17, 2010 8:17 pm
Location: Michigan
Contact:

Re: Lost trim piece, anyone have this happen?

Post by yowen » Thu Oct 14, 2010 3:43 pm

Great... I was excited to have car that wouldn't fall apart in a car wash. Guess I was wrong.
2006 Ford 500 SE, Dark Blue, 116,000 Miles
- JVC KD-LHX500 Deck

Edsel II
Regular Member
Posts: 531
Joined: Wed Jul 25, 2007 2:38 pm

Re: Lost trim piece, anyone have this happen?

Post by Edsel II » Thu Oct 14, 2010 5:55 pm

If you have an '05, get ready for your side moldings to come off too if you use beater brush type car washes...

yowen
Regular Member
Posts: 55
Joined: Thu Jun 17, 2010 8:17 pm
Location: Michigan
Contact:

Re: Lost trim piece, anyone have this happen?

Post by yowen » Thu Oct 14, 2010 5:58 pm

good thing I have an 06?

Is there a way for me to install new ones that won't rip off?
2006 Ford 500 SE, Dark Blue, 116,000 Miles
- JVC KD-LHX500 Deck

Edsel II
Regular Member
Posts: 531
Joined: Wed Jul 25, 2007 2:38 pm

Re: Lost trim piece, anyone have this happen?

Post by Edsel II » Fri Oct 15, 2010 10:41 am

Not sure, but they might have updated the mounting clips due to the problems with the roof piece coming off.

User avatar
Serge_L
Regular Member
Posts: 31
Joined: Sun Dec 14, 2008 1:38 am
Location: Ontario, Canada

Re: Lost trim piece, anyone have this happen?

Post by Serge_L » Thu Mar 31, 2011 1:55 am

Happened on my '07, iin the dryer section of a touchless carwash. I collected it from inside the carwash, there was one clip missing. Went to the dealer to enquire about replacement; was something like $200 for the part, plus it has to be painted (they donù,t sell the individual clips).

Finally got it replaced under warranty.
2007 Ford Five Hundred Limited - AWD w. CVT - Moonroof - Alloy Clearcoat on Black.
2006 Ford Focus SE - w. MTX75 - Moonroof - Dark Shadow Grey on Grey.
Anxiously waiting for the Mondeo to reach these shores.

FordFrankenstein
Regular Member
Posts: 12
Joined: Tue Oct 22, 2013 8:39 pm

Re: Lost trim piece, anyone have this happen?

Post by FordFrankenstein » Tue Oct 22, 2013 9:21 pm

Mine was loose, and when my windshield got replaced, the guy took the rubber tip of it, and slit it under the rubbe seal for the windshield, he's smarter than ford because it worked perfectly, and it's more fun to shoot your car with a squrt gun :p that and you can get it more clean

Post Reply