Page 1 of 1

Ford Five Hundred 2007 SEL

Posted: Tue Aug 23, 2016 8:29 pm
by RachelAnn
So, I just bought my Ford Five Hundred 2007 SEL in April of 2016. My car isn't even at 150,000 miles yet. (I think it just rolled over to 138,000) I bought the car used & from a "Chrysler Jeep Dodge" dealership which was my first mistake.

So, it's been recently stalling on me. It's also dropped the dash needles a couple of times, Ive had to turn the key over twice because the first time it doesn't want to start. Now the dash is completely off.. no light and the needles get stuck at whatever speed you where going.

Does anyone else have this issue?
I'm located in Michigan.
Thank you.

Re: Ford Five Hundred 2007 SEL

Posted: Wed Aug 24, 2016 11:38 am
by warment
Not sure about the stalling...probably an electrical throttle body issue.

Needle drop (I have had this happen a few times on my 2005). Check that the elec plug under the dash (near where your knees are when sitting in the driver seat) is connected as it should be. The first time my needles dropped, it was because the elec plug was not completely plugged in and did not have the little plastic arm completely locked into place.

viewtopic.php?t=15742

Re: Ford Five Hundred 2007 SEL

Posted: Wed Aug 24, 2016 11:40 am
by warment
The TB is very easy to replace (if this is your issue). I recently replaced mine when the car repeatedly went into limp mode while driving. Just make sure you get the correct TB (some are "heated" and have a coolant line, and some do not).