If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Search found 20 matches

by imnotok
Fri Apr 27, 2012 9:22 am
Forum: Under the Hood
Topic: Battery or Alternator?
Replies: 6
Views: 786

Re: Battery or Alternator?

Got it done faster than expected. Only paid $404!
by imnotok
Fri Apr 27, 2012 8:22 am
Forum: Under the Hood
Topic: Battery or Alternator?
Replies: 6
Views: 786

Re: Battery or Alternator?

Thank you both.

It was the alternator. Had it checked first thing today. Total cost is $483.
by imnotok
Thu Apr 26, 2012 7:39 pm
Forum: Under the Hood
Topic: Battery or Alternator?
Replies: 6
Views: 786

Battery or Alternator?

05 Montego Luxury November the battery was 100% February the battery was 50% On my way home I had no warning lights, but my radio went out. Then my ABS/Traction Control light flickered and the panel went nuts then died. I was able to get into my driveway before the battery gave out. I got a new batt...
by imnotok
Tue Feb 28, 2012 2:38 am
Forum: Under the Hood
Topic: Changed my 6-speed fluid
Replies: 123
Views: 17934

Re: Changed my 6-speed fluid

So I bought 4 qts. on Saturday of the Ford ATF and they were $8.25 each. I was getting an oil change and figured since he was under there it would be cost efficient to see if they'd pull the plug for a drain/refill. I had to convince them to do it since it wasn't an immediate problem....and they cha...
by imnotok
Tue Feb 28, 2012 2:19 am
Forum: Under the Hood
Topic: Valve stems...
Replies: 1
Views: 360

Valve stems...

This isn't a question as it is an odd story. Since I got my car, 05 Montego Luxury, I noticed a metallic clink when I'd accelerate from a stop or into a turn. It didn't hurt anything, but it annoyed me. I had it checked 4 times (during oil changes, tire rotation, etc...) and nobody could figure it o...
by imnotok
Sun Jan 22, 2012 8:14 pm
Forum: Under the Hood
Topic: Rear dome light...
Replies: 2
Views: 571

Rear dome light...

I am changing the interior lights to red. Love how the front looks, but I can't get the rear one off. Anyone know how?
by imnotok
Tue Dec 27, 2011 11:01 pm
Forum: Under the Hood
Topic: Vibration...
Replies: 4
Views: 712

Re: Vibration...

Happens anytime I am in that rpm band. And yeah I'd say mild accel. It goes away when I give it more pressure. The gears shift smooth as silk, hardly even feel it.
by imnotok
Tue Dec 27, 2011 6:58 pm
Forum: Under the Hood
Topic: Vibration...
Replies: 4
Views: 712

Vibration...

It's getting annoying now. It seems to appear between 1000 and 1500 rpms. I feel it in the floor board and the gas pedal. Has anyone else had that? It's not jarring. Its light, but enough to be annoying. If I press harder on the pedal it goes away. I had the transmission fluid checked (its fine), th...
by imnotok
Tue Dec 20, 2011 11:27 pm
Forum: Under the Hood
Topic: Low speed squeak
Replies: 6
Views: 1068

Re: Low speed squeak

I don't really worry about it because right after I bought the car (Used at 60k and i'm at 64k now) I noticed the rear brakes were grinding and were warped so the dealer gave me all new pads and rotors all the way around. When the weather got a little colder it started, but all the hardware is good ...
by imnotok
Tue Dec 20, 2011 10:17 pm
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 40904

Re: Engine mount shot

I had the heat on. But I figured there was a small leak since it was a common problem after the top mount goes. I tried to piece some things together after I saw the top mount. During acceleration I sometimes get this vibration in the floor board. It's not speed dependent, it's rpm dependent and aft...
by imnotok
Tue Dec 20, 2011 10:07 pm
Forum: Under the Hood
Topic: Low speed squeak
Replies: 6
Views: 1068

Re: Low speed squeak

I'm going to bet its the brakes. Mine do it in the morning, when they get wet, or it sits for a while. It normally goes away after I come to a good stop.
by imnotok
Tue Dec 20, 2011 12:46 am
Forum: Under the Hood
Topic: 2006 Ford 500 AWD CVT TRANSMISSION ISSUE / ADVICE NEEDED
Replies: 8
Views: 3670

Re: 2006 Ford 500 AWD CVT TRANSMISSION ISSUE / ADVICE NEEDED

Did you take it to the dealer or an independent shop? Maybe you could get a second or third opinion. I have a Montego and I love it. I'm slowly working my way through all the little maintenance things, but it's a solid car. I bought an 2000 explorer in 04 with 80k miles and I drove it to 204k and I ...
by imnotok
Mon Dec 19, 2011 7:36 pm
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 40904

Re: Engine mount shot

Water coming out of the tailpipe is fine. Did you visually see a coolant leak? Or was the level just a little low? Where was the coolant leak if you saw one? What year is your car anyways? The exhaust water is closer to the center of the car and it is also random when it happens, just a drop or two...
by imnotok
Mon Dec 19, 2011 4:55 pm
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 40904

Re: Engine mount shot

My drill did not agree with the dogbone so for now I cut a coat hanger, wrapped it, and tightened. So far so good. But I noticed a slight coolant leak. Maybe 3 or 4 drops and it is very random when it happens. The fluid level is fine. I think the have engine may have done it. And finally there are a...
by imnotok
Mon Dec 19, 2011 10:16 am
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 40904

Re: Engine mount shot

imnotok, are you talking about the volvo replacement bushing replacement of the trans roll resistor bushing? If so, I recomment you do what I did... "I cut more metal than needed (so the metal part of the bushing wasn't flush with the mount), but my bushing was shifting to the side and making conta...
by imnotok
Sun Dec 18, 2011 3:50 pm
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 40904

Re: Engine mount shot

I got it in but it shifted. Can I use glue or rubber cement to keep it stationary?
by imnotok
Sun Dec 18, 2011 3:48 pm
Forum: Under the Hood
Topic: 05 Montego chime...
Replies: 3
Views: 541

Re: 05 Montego chime...

Thank you. I bet that was it.
by imnotok
Sat Dec 17, 2011 9:21 pm
Forum: Under the Hood
Topic: 05 Montego chime...
Replies: 3
Views: 541

05 Montego chime...

This could be a dumb question, but my previous vehicles didn't have half the system controls and monitors this car has. Today, I was on a circle on-ramp and as I was merging left I heard a single chime and I noticed my message center changed briefly, but it went away before I could read it. No other...
by imnotok
Tue Dec 13, 2011 12:56 am
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 40904

Re: Engine mount shot

This is exactly why I love this forum. I bought an 05 Montego with 60k in October and something didn't feel right when accelerating. So I search through tons of websites looking for answers and then I find this. I go check my engine this morning and low and behold, the upper mount needs to be replac...
by imnotok
Sun Dec 04, 2011 5:22 pm
Forum: Interior
Topic: Interior lighting...
Replies: 4
Views: 1122

Interior lighting...

I have an 05 Montego Luxury. My instrument panel lights up fine, but there's no illumination on the power window control, the switches on each side of the steering wheel, and the knob for the head lights. Can it be a fuse? Or does it need new bulbs (if so, how can I find them?).

Thanks in advance.