If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Search found 7 matches

by martinm76
Wed Jan 26, 2011 6:58 pm
Forum: Under the Hood
Topic: CVT longevity??
Replies: 22
Views: 2204

Re: CVT longevity??

The cvt is very hard on fluid as it gets pretty hot, the tranny cooler for the CVT is bigger than the radiator on some small import cars. I suggest replacing the fluid by the book which if I remember correctly was drain and fill at 30k then drop the pan and do both internal and external filters at 6...
by martinm76
Wed Jan 26, 2011 6:41 pm
Forum: Under the Hood
Topic: took car to the dealer and have some questions
Replies: 3
Views: 437

Re: took car to the dealer and have some questions

That seems to be a new thing with dealers as I never had issues before getting a car serviced at a dealership under warranty. A friend of mine owns a brand new Nissan and had some issues with it at about 3,000 miles. When he took it into the dealer they wanted almost $200 up front in cash for a diag...
by martinm76
Wed Jan 26, 2011 6:35 pm
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 63136

Re: Engine mount shot

Worked very well for me, highly recommended for a cheap fix. Mine had deteriorated so bad that once i moved everything out of the way the center part fell out. I was able to get the new one in there with a little bit of difficulty but that was good because the left over rubber holds the new bushing ...
by martinm76
Wed Jan 26, 2011 6:31 pm
Forum: Under the Hood
Topic: headlight bulb blows out
Replies: 3
Views: 432

Re: headlight bulb blows out

I had this issue in my mother's 500 and kept replacing bulbs and sockets till I finally decided to do it differently. I replaced both the bulbs and sockets and cut the factory ground wire off and ran my own chassis ground to both headlights and it has been good since. I ran into this on an escort ZX...
by martinm76
Wed Jan 26, 2011 6:27 pm
Forum: Under the Hood
Topic: Yellow Wrench light?
Replies: 4
Views: 1897

Re: Yellow Wrench light?

Now that I think about it the original tranny in the car was turning on the yellow wrench light and setting two codes one for speed sensor and one for something about two signal values not agreeing with each other. But after I put in the new tranny I still got the same codes when I scanned it at wor...
by martinm76
Wed Jan 26, 2011 6:17 pm
Forum: Under the Hood
Topic: Yellow Wrench light?
Replies: 4
Views: 1897

Re: Yellow Wrench light?

I appreciate the replies. At the time I wrote that post I had a chance to fiddle with the car a bit since my mother was visiting me and I had the car here. I had it buck for me many times since it has become a daily thing with it at this point. Before she went back home which is almost 400 miles I h...
by martinm76
Thu Dec 16, 2010 12:26 am
Forum: Under the Hood
Topic: Yellow Wrench light?
Replies: 4
Views: 1897

Yellow Wrench light?

Having a bunch of trouble with this 06 Five hundred and wonder if anyone has any suggestions from their experience? Little bit of background on the car. I bought the car with a bad cvt tranny at 72k. It sounded like a Volkswagen TDI in Park and Neutral but got silent in drive till you got rolling. T...