If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Search found 20 matches

by kchamp
Fri May 21, 2010 9:05 pm
Forum: Under the Hood
Topic: Type of spark plugs...
Replies: 0
Views: 357

Type of spark plugs...

Has anyone changed the spark plugs in their cars? What kind of plugs have you used? Was their a difference between motorcraft vs other brands? I know you have to change the plenum gaskets when changing the plugs. I just want the get the most out of this car with the best products. Thanks
by kchamp
Fri May 14, 2010 8:01 pm
Forum: Exterior
Topic: Has anyone installed aftermarket (Lowering) springs
Replies: 26
Views: 7128

Re: Has anyone installed aftermarket (Lowering) springs

I found eibach sport springs for the 500... Lowers the car a lot though. 1.8 inches and 1.9inches. I don't think I'd lower it that much and risk the chance of bottoming out on the transmission or oil pan
by kchamp
Fri May 14, 2010 7:58 pm
Forum: Under the Hood
Topic: K&N air filter or standard air filter???
Replies: 6
Views: 965

K&N air filter or standard air filter???

I have had great experiences with K&N filters in the past. So I was wondering if anyone uses a K&N air filter and notices a difference? Thanks
by kchamp
Fri Jan 15, 2010 3:05 pm
Forum: Under the Hood
Topic: Engine mount shot
Replies: 117
Views: 47888

Engine mount shot

I am little upset to see the engine mount on top of the engine that connects to the cross bar is shot. The rubber is all torn and ripped apart. I am upset because the car was in the dealership the other day and they should have seen this. Going back in on tuesday and they will hear an earful. If the...
by kchamp
Thu Jan 14, 2010 2:19 pm
Forum: Under the Hood
Topic: Knocking noise when turning hard
Replies: 7
Views: 1670

Re: Knocking noise when turning hard

Dealer lubed the stops and no noise is present at this time. Found it as a bit of a surprise since it was not a full turn.
by kchamp
Mon Jan 11, 2010 4:39 pm
Forum: Under the Hood
Topic: Knocking noise when turning hard
Replies: 7
Views: 1670

Re: Knocking noise when turning hard

Found a posting elsewhere that it could be the strut mounts. Bringing it to the dealer tomorrow. Will post up once and if they find anything.
by kchamp
Sun Jan 10, 2010 9:29 pm
Forum: Under the Hood
Topic: Knocking noise when turning hard
Replies: 7
Views: 1670

Re: Knocking noise when turning hard

It's not at a full turn but close.
by kchamp
Thu Jan 07, 2010 9:53 pm
Forum: Under the Hood
Topic: Knocking noise when turning hard
Replies: 7
Views: 1670

Knocking noise when turning hard

When I turn the steering wheel hard to either side it makes a knocking noise. A noise Unlike a bad cv joint/axle. I hear this mostly when in reverse at slow speeds. Do you think it is the rack and pinion or a bad tie rod or sway bar? Anyone have this experience??? Thanks
by kchamp
Wed Dec 09, 2009 3:34 pm
Forum: Five Hundred / Montego Reviews
Topic: Tires for Five Hundred
Replies: 22
Views: 5509

Re: Tires for Five Hundred

The coopers I put on my 500 are 80k tires. They are quiet great in the rain and surprisingly very good in the snow. Drove today in 6 inches of unplowed snow with not one slip or issue. So far I am happy with them.
by kchamp
Wed Dec 09, 2009 3:29 pm
Forum: Under the Hood
Topic: shifting issues
Replies: 11
Views: 2408

Re: shifting issues

I just purchased the 500 2 weeks ago with 48k on it. I did one change of fluid 3 1/2 quarts and plan on doing another next week. Other than that the 500 is a very nice car. I am happy with it.
by kchamp
Tue Dec 08, 2009 4:47 pm
Forum: Under the Hood
Topic: shifting issues
Replies: 11
Views: 2408

Re: shifting issues

I have changed the fluid already. It doesn't do it in the downshift. It does it in the upshift. It will hesitate before shifting especially going uphill. Sometimes when i let go of the gas it will shift. I looked up the TSB's and recalls for the 2007 and there is almost none. The fluid was brown whe...
by kchamp
Tue Dec 08, 2009 12:35 pm
Forum: Under the Hood
Topic: shifting issues
Replies: 11
Views: 2408

shifting issues

I have had my car for about 2 weeks now. I notice at times it does not want to up shift without taking my foot off of the accelerator. I have experienced this before with a different vehicle I have had. I had the computer flashed and fixed the problem. I believe all I need is to get the tranny flash...
by kchamp
Sun Dec 06, 2009 9:16 pm
Forum: Under the Hood
Topic: Oil and Oil filter preference
Replies: 10
Views: 2064

Oil and Oil filter preference

I just wanted to know what you guys prefer for oil and oil filter in the 500...


I recently bought the Motorcraft 5w20 from Walmart with a motorcraft filter for under $20...

I am not sure if i should keep with a synthetic blend or go with a full synthetic with this car. What do you think?
by kchamp
Fri Dec 04, 2009 4:57 pm
Forum: Under the Hood
Topic: Changed my 6-speed fluid
Replies: 123
Views: 18187

Re: Changed my 6-speed fluid

did the change today. Made a huge difference right off the bat. Super easy to do. I ended up popping off the air cleaner box to access the dip stick. I added about 3 1/2 quarts. The old stuff was brown compared to the nice bright red new fluid.
by kchamp
Wed Dec 02, 2009 2:12 pm
Forum: Exterior
Topic: Taurus Front end on a Five Hundred?
Replies: 4
Views: 944

Re: Taurus Front end on a Five Hundred?

I don't see why you couldn't do it. I have done it with a VW jetta and VW golf and was just a swap over. Also looked nice.
by kchamp
Wed Dec 02, 2009 12:13 pm
Forum: Under the Hood
Topic: Changed my 6-speed fluid
Replies: 123
Views: 18187

Re: Changed my 6-speed fluid

Where is the drain plug located? I think I saw it when I glanced under the car yesterday but I want to make sure. Thanks
by kchamp
Wed Dec 02, 2009 10:57 am
Forum: Five Hundred / Montego Reviews
Topic: Just picked up an 07 500
Replies: 11
Views: 1552

Re: Just picked up an 07 500

I was a service advisor until the economy tanked and then got laid off with 3 others the same day. I enjoyed the work.
by kchamp
Tue Dec 01, 2009 10:36 pm
Forum: Five Hundred / Montego Reviews
Topic: Just picked up an 07 500
Replies: 11
Views: 1552

Just picked up an 07 500

I just bought a 2007 500 SEL with the 6 speed tanny. It has 48k on it and I bought it for $9600. I love the room of this car. It was a fleet vehicle so I am doing a good thorough service. I worked for Ford and loved the new taurus but I didn't want to spend the money for a new one so I settled for t...
by kchamp
Tue Dec 01, 2009 10:31 pm
Forum: Five Hundred / Montego Reviews
Topic: Tires for Five Hundred
Replies: 22
Views: 5509

Re: Tires for Five Hundred

I ended up buying a set of Cooper CS4 tires for my car and I am happy with them so far.
by kchamp
Tue Dec 01, 2009 10:29 pm
Forum: Under the Hood
Topic: Changed my 6-speed fluid
Replies: 123
Views: 18187

Re: Changed my 6-speed fluid

I plan on changing my fluid as well. I called local dealers today and one dealer asked for 1 quart of fluid $18.50 I laughed. I ended up ordering it online for 5.26 a quart.